Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #48

Служба Рассылок Subscribe.Ru проекта Citycat.Ru
Информационные технологии: CASE, RAD, ERP, OLAP.
Новости, анонсы событий мира информационных технологий и инструментальных средств для компьютерного бизнеса. Предложение ознакомительных версий, документации, патчей, freeware, shareware, книг, CD, услуг по обучению, сертификации, консалтингу.
Подписаться. Рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 48 от 27.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол UDP

Протокол User Datagram Protocol (UDP) обеспечивает не ориентированную на соединение службу доставки датаграмм по принципу "максимального усилия". Это означает, что получение всей датаграммы или правильной последовательности отправленных пакетов не гарантируется.

Протокол UDP используется приложениями, не требующими подтверждения. Обычно такие приложения передают данные небольшого объема за один раз. Примеры служб и приложений, использующих UDP: сервис имен NetBIOS, сервис датаграмм NetBIOS и сервис SNMP.

Для использования протокола UDP приложение должно знать IP-адрес и номер порта получателя. Порт - место назначения при доставке сообщений - идентифицируется уникальным номером. Порт действует как мультиплексная очередь сообщений, то есть он может получать несколько сообщений одновременно. Важно отметить, что порты протокола UDP, перечисленные в таблице, отличаются от портов TCP, несмотря на использование тех же значений номеров.

Номер порта | Ключевое слово | Описание
15 | NETSTAT | Состояние сети
53 | DOMAIN | Сервер имен домена
69 | TFTP | Протокол TFTP
137 | NETBIOS-NS | Сервис имен NetBIOS
138 | NETBIOS-DGM | Сервис датаграмм NetBIOS
161 | SNMP | Сетевой мониторинг SNMP

Протокол UDP описан в RFC 768.

Поля 8-байтного заголовка UDP-пакета перечислены в таблице:

Поле | Описание
Source Port (Порт отправителя) | UDP-пор узла-отправителя. Его задавать необязательно. Если не используется, то устанавливается равным нулю.
Destination Port (Порт получателя) | UDP-порт узла-получателя. Указывает конечную точку соединения.
Message Length (Длина сообщения) | Размер сообщения. Минимальный UPD-пакет содержит только информацию заголовка (8 байт)
Checksum (Контрольная сумма) | Проверяет заголовок на предмет повреждения

На сегодня все, любые пожелания, вопросы и комментарии присылайте по адресу hp@pisem.net.
Архив рассылки и другую информацию вы можете найти по адресу http://www.windows.sl.ru/subscribe.
Задать любые вопросы, касающиеся компьютеров, вы можете в форуме или подписавшись на группу общения.
Copyright Николай Басманов 2000-2001
Перепечатка разрешена только со ссылкой на сайт http://www.windows.sl.ru.
Рассылка автоматически создана программой WOE Subscribe Maker.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #47

Партнерская программа "Высокий Старт"
продлена до 31 августа!!!
Не упустите возможность- бронируйте
рекламу на осень со СКИДКОЙ
Подробнее на сайте Subscribe.Ru >>
Реклама
Энциклопедия оптимизации Windows
Выпуск # 47 от 24.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Структура TCP-пакета

Все пакеты протокола TCP имеют две части - на данные и заголовок. В таблице приведены поля заголовка TCP-пакета.

Поле | Описание
Source Port (Порт отправителя) | TCP пор узла-отправителя
Destination Port (Порт получателя) | TCP пор узла-получателя. Определяет конечную точку соединения
Sequence Number (Порядковый номер) | Номер последовательности пакета. Используются для проверки получения всех байт соединения
Acknowledgement Number (Номер подтвержения) | Порядковый номер байта, который локальный узел планирует получить следующим
Data Length (Длина данных) | Длина TCP-пакета
Reserved (Зарезервировано) | Зарезервировано для дальнейшего использования
Flags (Флаги) | Это поле описывает содержимое сегмента
Windows (Окно) | Показывает, сколько места доступно в настоящий момент в окне протокола TCP
Checksum (Контрольная сумма) | Проверяет, поврежден ли заголовок
Urgent Pointer (Указатель срочности) | Когда отправляются срочные данные (указано в поле Flags), в этом поле задается конечная граница области срочных данных в пакете

На сегодня все, любые пожелания, вопросы и комментарии присылайте по адресу hp@pisem.net.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #46

Энциклопедия оптимизации Windows
Выпуск # 46 от 22.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Установка связи по протоколу TCP

Инициализация TCP-соединения происходит в три этапа. Делается это для синхронизации отправки и получения сегментов, извещения другого узла о количестве данных, которые можно послать за один раз, и установки виртуального соединения.

Вот из каких операций состоит этот процесс:

  1. Узел-отправитель запрашивает соединение, посылая сегмент с установленным флагом синхронизации (SYN).
  2. Узел-адресат подтверждает получение запроса, отправляя обратно сегмент с:
    • Установленным флагом синхронизации.
    • Порядковым номером начального байта сегмента, который он может послать или номером последовательности (sequence number).
    • Подтверждением, включающим порядковый номер следующего сегмента, который он ожидает получить.
  3. Запрашивающий узел посылает обратно сегмент с подтверждением номера последовательности и номером своего подтверждения (acknowledgement number).

Для завершения соединения TCP действует аналогично. Это гарантирует, что оба узла закончат передачу и примут все данные.

Протокол TCP буферизирует данные для передачи между двумя узлами, используя скользящие окна (sliding windows). Каждый TCP/IP узел поддерживает два скользящих окна: одно для приема данных, а другое - для отправки. Размер окна определяет объем данных, которые могут быть буферизированы на компьютере.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #45

Энциклопедия оптимизации Windows
Выпуск # 45 от 20.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Порты и сокеты

Приложения, использующие сокеты, идентифицирую себя на компьютере посредством номера порта протокола (protocol port number). Например, FTP-сервер использует определенный tCP-порт, поэтому другие приложения могут с ним связаться.

Порты могут иметь любой номер от 0 до 65536. Номера портов для приложений клиентов динамически назначаются операционной системой при обработке запроса на обслуживание. Известные (well-known) номера портов для приложений-серверов назначаются группой Internet Assigned Numbers Authority (IANA) и не меняются.

Вы можете узнать номера портов, просмотрев файл Service, находящийся в папке [C:\ W] в Windows 9x или [C:\ W\ System32\ Drivers\ Etc\ Services] в Windows NT.

Номера известных портов расположены в интервале от 1 до 1024. Окончательный список известных номеров портов задокументирован в RFC 1700.

Сокет (socket) во многом аналогичен дескриптору файла (file handler). Он обеспечивает конечную точку сетевого соединения. Приложение, создавая сокет, указывает три параметра: IP-адрес узла, тип обслуживания (протокол TCP для ориентированного на соединение обслуживания и UDP для не ориентированного) и порт, используемый приложением.

Приложение может создать сокет и использовать его для отправки не ориентированного на соединение трафика удаленным приложениям или же подключить его к сокету другого приложения. Во втором случае данные будут посланы по надежному соединению.

Порт протокола tCP указывает место доставки сообщений. Номера портов, меньшие 256, определены как широко используемые. В таблице перечислены некоторые из таких портов:

Номер порта | Описание
21 | FTP
23 | Telnet
53 | Доменная система имен (DNS)
139 | Сервис NetBIOS


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #44

MS SQL Server - дело тонкое....
Всё для MS SQL Server DBA и SQL программистов. Рассылка содержит разделы, посвящённые администрированию баз данных, обеспечению безопасности данных и программированию приложений баз данных.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 44 от 17.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол TCP

Протокол TCP предоставляет надежную, ориентированную на соединение службу доставки. Данные протокола TCP передаются сегментами, и соединение должно быть установлено до того, как узлы начнут обмениваться данными. TCP использует потоки, в которых данные представлены в виде последовательности байт.

TCP обеспечивает надежность, присваивая номера последовательности (sequence number) каждому передаваемому сегменту. Если сегмент разбивается на мелкие пакеты, то узел-получатель сможет узнать, все ли части получены. Для этого используются подтверждения. Для каждого отправленного сегмента узел-получатель должен вернуть отправителю подтверждение (acknowledgement, ACK) в течение определенного времени.

Если отправитель не получил ACK, то данные передаются повторно. Если сегмент поврежден, то узел-получатель отвергает его. Поскольку ACK в этом случае не посылается, отправитель передает сегмент еще раз.

TCP описан в RFC 793.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #43

Энциклопедия оптимизации Windows
Выпуск # 43 от 15.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Структура IP-пакета

Поля заголовка IP-Пакета (для IP версии 4) приведены в следующей таблице:

Поле | Описание
Version (Версия) | 4 бита используются для отображения версии протокола IP. Текущая версия - четвертая. Следующей будет шестая.
Header Length (Длина заголовка) | 4 бита используются для отображения количества 32-битных слов в заголовке IP-пакета. Минимальный размер слова - 20 байт, следовательно, длина минимального заголовка - 0x5. Опции IP могут увеличить минимальный размер заголовка на 4 байта. Если опция не использует их все, то оставшиеся биты заполняются нулями, поэтому длина заголовка всегда кратна 4 байтам.
Type of Service (Тип обслуживания) | 8 бит используются для обозначения требуемого для этой датаграммы качества обслуживания при доставке через маршрутизаторы объединенной IP-сети. В них есть биты, выделенные для приоритета, задержки, пропускной способности и характеристики надежности.
Total Length (Общая длина) | 16 бит используются для отображения общей длины датаграммы протокола IP (заголовок IP-пакета + его содержание). Сюда не включен заголовок сетевого кадра.
Identification (Идентификация) | 16 бит используются в качестве идентификатора данного IP-пакета. Если IP-пакет фрагментирован, то все фрагменты имеют одинаковые идентификаторы, используемые при сборке узлом-получателем.
Fragmentations Flags (Фрагментационные флаги) | 3 бита зарезервированы для флагов фрагментации, однако только 2 бита определены для текущего использования. Один флаг служит для обозначения фрагментированного пакета, другой - для идентификации последнего фрагмента.
Fragment Offset (Смещение фрагмента) | 13 бит используются как счетчик смещения для указания положения фрагментов относительно начала поля данных IP-пакета. Если фрагментации нет, то смещение равно 0x0.
Time To Live (Время существования) | 8 бит используются в качестве индикатора времени (транзитов IP-пакета), максимально допустимого перед тем, как пакет будет отвергнут. Поле TTL используется как счетчик времени (в секундах), проведенного пакетом на маршрутизаторе, который соответственно уменьшает TTL. Современные маршрутизаторы почти всегда перенаправляют датаграммы менее чем за 1 секунду, однако, по требованиям RFC 791, они должны уменьшать TTL не менее чем на единицу. Поэтому TTL становится счетчиком максимального числа транзитов.
Protocol (Протокол) | 8 бит используются в качестве идентификатора протокола, данные которого инкапсулированы в IP-пакет. Поле протокола применяется для передачи IP-пакета протоколу верхнего уровня.
Header Checksum (Контрольная сумма заголовка) | 16 бит используются в качестве контрольной суммы заголовка IP-пакета. Данные пакета не учитываются и могу иметь свою собственную контрольную сумму для проверки ошибок. Когда узел получает пакет, он проводит проверку контрольной суммы и при несовпадении значений отвергает пакет. Когда маршрутизатор пересылает пакет, он, как минимум, уменьшает TTL. Поэтому контрольная сумма вычисляется снова при каждом транзите ну пути от отправителя к получателю.
Source Address (Адрес отправителя) | 32 бита используются для хранения IP-адреса узла-отправителя.
Destination Address (Адрес получателя) | 32 бита используются для хранения IP-адреса узла-получателя.
Options and Padding (Опции и заполнение) | Для хранения опций используется кратное 32 число бит. Если же опции не занимают это место целиком, остаток заполняется нулями. Таким образом, длина IP-заголовка всегда может быть выражена количеством четверок байт и записана в поле Header Length.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #42

Анонсы Lenta.Ru.
Круглосуточные новости с сервера Lenta.Ru. Все важное, что случилось за последние часы в России и мире, в экономике и в Чечне, в медицине, в кино и в спорте - по мере поступления.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 42 от 13.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Реализация IP на маршрутизаторе

Маршрутизатор обрабатывает полученные им IP-пакеты следующим образом.

  1. Уменьшает значение TTL на 1 секунду или больше, если пакет надолго задерживается на маршрутизаторе. Если значение TTL достигает нуля, пакет отвергается.
  2. Пакет может быть фрагментирован, если его размер слишком велик для сети дальнейшего следования.
  3. Если пакет фрагментирован, то IP создает для каждого нового пакета (фрагмента) отдельный заголовок, устанавливая:
    • Flag (флаг), указывающий, что существуют и другие фрагменты, которые будут отправлены следом.
    • Fragment ID (Идентификатор фрагмента), идентифицирующий все фрагменты, составляющие один пакет.
    • Fragment Offset (Смещение фрагмента), обеспечивающее правильную сборку пакета на узле-получателе.
  4. Вычисляет новую контрольную сумму.
  5. Определяет адрес сетевого адаптера следующего маршрутизатора.
  6. Направляет пакет дальше в сеть.
На следующем уровне пакет попадает по стеку протоколов к TCP или UDP. Этот процесс повторяется на каждом маршрутизаторе до тех пор, пока пакет не дойдет до адресата. Там протокол IP собирает из фрагментов пакет в первоначальном виде.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #41

Энциклопедия оптимизации Windows
Выпуск # 41 от 10.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол IP

Протокол IP не ориентирован на соединение, поскольку он не устанавливает сеанс связи перед тем как начать обмен данными. Протокол IP ненадежный - он не гарантирует доставку, хотя делает все возможное для доставки пакета. По пути пакет может быть потерян, доставлен в неправильной последовательности, продублирован или задержан.

Протокол IP не требует подтверждения при приеме данных. Отправитель или получатель не информируются при потере пакета или доставке его в неправильной последовательности. Ответственность за подтверждение получения пакетов несут высокоуровневые транспортные протоколы, например, TCP.

Поля IP-датаграммы в приведенной ниже таблице добавляются в заголовок пакета при его получении с транспортного уровня.

Поле | Описание
Source IP-address (IP-адрес отправителя) | Идентифицирует отправителя датаграммы при помощи IP-адреса.
Destination IP-address (IP-адрес получателя) | Идентифицирует получателя датаграммы при помощи IP-адреса.
Protocol (Протокол) | Информирует протокол IP узла-получателя о том, какому протоколу верхнего уровня - TCP ил UDP - его следует передать.
Checksum (Контрольная сумма) | Легко вычисляемое значение для проверки целостности пришедшего пакета.
Time to live, TTL (Время жизни) | Определяет, сколько секунд находится датаграмма в сети перед тем, как она будет отвергнута (discarded). Предотвращает бесконечное блуждание пакетов по сети. Маршрутизаторы должны уменьшать TTL на количество секунд, проведенных датаграммой на маршрутизаторе. TTL уменьшается по меньшей мере на 1 секунду каждый раз, когда датаграмма проходит через маршрутизатор. По умолчанию в Windows NT 4.0 TTL равно 128 секундам.

Если протокол IP идентифицирует адрес получателя как локальный, то он передаст пакет на этот узел напрямую. Если же IP-адрес получателя идентифицирован как удаленный, то IP начнет искать маршрут к удаленному узлу в локальной таблице маршрутизации. Если он не найдет подходящего маршрута, то отправит пакет на шлюз по умолчанию, заданный в конфигурации узла-отправителя. Шлюз по умолчанию (default gateway) также называют маршрутизатором (router).

Протокол IP описан в RFC 791.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #40

Еженедельные Гороскопы от Ignio.
Еженедельный астрологический прогноз
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 40 от 08.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол IGMP

Информация протокола IGMP проходит через другие маршрутизаторы таким образом, что каждый поддерживающий групповую адресацию маршрутизатор знает, какая группа узлов в какой сети находится. Пакеты IGMP передаются датаграммами протокола IP и поэтому ненадежны.

Структура IGMP-пакета представлена в следующей таблице:

Год | Событие
Version (Версия) | Версия протокола IGMP. Данное поле имеет фиксированное значение 0x1.
Type (Тип) | Тип IGMP-сообщения. Тип 0x1 называется Host Membership Query (запрос узла о принадлежности к некоторой группе) и используется групповыми маршрутизаторами для опроса нескольких членов указанной группы. Тип 0x2 - Host Membership Report (ответ узла о принадлежности к некоторой группе) - используется для объявления членства в группе или для ответа на запрос Host Membership Query, поступивший от маршрутизатора.
Unused (Не используется) | Не используемое поле. Обнуляется отправителем и игнорируется получателем.
Checksum (Контрольная сумма) | 16-битная контрольная сумма на 8-байтный заголовок IGMP-пакета.
Group Address (Групповой адрес) | Используется узлами в сообщении Host Membership Report для хранения группового IP-адреса. В запросе Host Membership Query групповой адрес заполняется нулями, а для идентификации группы узлов используется широковещательный адрес сетевого адаптера.

Протокол IGMP описан в RFC 1112.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #39

Руническая магия.
С помощью этой рассылки Вы узнаете значения рун и познакомитесь с принципами магического воздействия на мир с их помощью. Весь представленный материал основан на практическом опыте автора рассылки.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 39 от 06.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол ICMP

В то время как протокол IP используется для маршрутизации в объединенных сетях, протокол ICMP (Internet Control Message Protocol) оповещает об ошибках и управляет сообщениями для протокола IP.

Протокол ICMP не используется для повышения надежности IP. Он лишь сообщает об ошибках и обеспечивает обратную связь в некоторых случаях. Сообщения протокола ICMP передаются в виде IP-датаграмм и поэтому ненадежны.

Если узел TCP/IP посылает датаграммы другому узлу со скоростью, перегружающей маршрутизаторы или каналы между ними, то маршрутизаторы могут ответить сообщением ICMP Source Quench, содержащим предложение снизить скорость передачи. Узел TCP/IP под управлением Windows NT выполняет это требование и уменьшает скорость отправки датаграмм. Однако, если компьютер, работающий под управлением Windows NT (если служба Routing and Remote Access Update не установлена), используется как маршрутизатор и не успевает перенаправлять датаграммы, он отвергает все датаграммы, которые нельзя буферизировать. В таком случае он не посылает ICMP-сообщения отправителям.

Структура ICMP-пакета представлена в следующей таблице:

Поле | Описание
Type (Тип) | 8-битное поле Type отображает тип пакета протокола ICMP (Echo Request, Echo Reply и т.д.).
Code (Код) | 8-битное поле Code отображает одну из нескольких возможных функций для данного типа пакета. Если в типе только одна функция, то значение в поле Code устанавливается равным 0.
Checksum (Контрольная сумма) | 16-битовая контрольная сумма части пакета, относящаяся к протоколу ICMP.
Type-Specific Data (Специальные данные типа) | Дополнительные данные, различные для каждого типа пакета.

Протокол ICMP описан в RFC 792.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #38

3DNews.
новости и анонсы всех вышедших на сайте обзоров.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 38 от 03.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Структура ARP-пакета

Хотя протокол ARP был разработан для разрешения именно IP-адресов, структура ARP-пакета может быть использована и для разрешения адресов других типов. Кадрам, содержащим ARP-пакеты, в поле EtherType соответствует значение 0x08-06. Поля пакета ARP показаны в таблице.

Поле | Описание
Hardware Type (Тип аппаратного обеспечения) | Задается тип используемого сетевого оборудования (Network Access Layer), например, Ethernet.
Protocol Type (Тип протокола) | С помощью значений поля EtherType кадра Ethernet задается используемый при разрешении адресов протокол. Для протокола IP значение поля Protocol Type равно 0x08-00.
Hardware Address Length (Длина адреса сетевого адаптера) | Задается длина адреса сетевого адаптера в байтах. Для Ethernet и Token Ring длины равны 6 байтам.
Protocol Address Length (Длина адреса протокола) | Задается длина адреса протокола в байтах. Для протокола IP длина равна 4 байтам.
Operation (Opcode) (Операция (Код операции)) | Задается выполняемая операция.
Sender's Hardware Address (Адрес сетевого адаптера отправителя) | Задается адрес сетевого адаптера отправителя.
Sender's Protocol Address (Адрес протокола отправителя) | Задается адрес протокола отправителя.
Target's Hardware Address (Адрес сетевого адаптера получателя) | Задается адрес сетевого адаптера получателя.
Target's Protocol Address (Адрес протокола получателя) | Задается адрес протокола получателя.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #37

Интересные компьютерные новости.
Иллюстрированные компьютерные новости. Самые интересные достижения индустрии, самые интересные продукты. Все это - два раза в неделю в максимально легком виде. Любопытно и со вкусом. Плюс рубрика "субъективная линия" - обзоры статей на русских "железных" сайтах с нашими комментариями.
Подписаться. Рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 37 от 01.08.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Кэш протокола ARP

Для уменьшения числа широковещательных пакетов ARP кэширует адреса для последующего использования. Применяются два типа записей в кэше ARP: динамические и статические. Первые добавляются и удаляются автоматически. Вторые находятся в кэше до перезагрузки компьютера.

В дополнение к этому в кэше протокола ARP всегда присутствует адрес для широковещания в локальной подсети (FFFFFFFFFFFF) в виде статической записи, которая не отображается при просмотре кэша.

По умолчанию для кэша протокола ARP установлены тайм-ауты, равные 2 минутам для невостребованных записей и 10 минутам для записей, к которым обращались.

В некоторых реализациях TCP/IP при повторном использовании записи ей присваивается новая отметка о времени поступления, которая добавляет дополнительные 10 минут ко времени ее жизни. В Windows NT эта функция не реализована.

Добавление статической ARP-записи уменьшает количество ARP-запросов для узлов, к которым обращаются достаточно часто. На компьютере, работающем под управлением Windows NT, статическая запись, добавленная в кэш ARP, доступна до:

  • Перезагрузки компьютера
  • Удаления записи вручную при помощи команды
    arp -d
  • Получения в широковещательном ARP-сообщении другого адреса сетевого адаптера (в этом случае тип записи меняется со статического на динамический и полученный в сообщении адрес заменяет текущий).

Если вы вручную помещаете запись в кэш протокола ARP, то адрес сетевого адаптера в команда

arp
следует разделять дефисами.

Возможны ситуации, когда протокол ARP не сумеет по заданному IP-адресу выяснить адрес сетевого адаптера. Если кэш протокола ARP содержит неправильный адрес сетевого адаптера, то попытка установить связь с удаленным узлом прекращается по истечении некоторого времени.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #36

Энциклопедия оптимизации Windows
Выпуск # 36 от 30.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Разрешение удаленного IP-адреса

Протокол ARP также позволяет связываться двум узлам из различных сетей. В этом случае широковещательный ARP-запрос обеспечивает возможность выяснить адрес используемого отправителем шлюза по умолчанию, а не узла-получателя. Если получатель находится в удаленной сети, то широковещательный ARP-запрос используется для поиска маршрутизатора, который может пересылать пакеты в эту сеть.

При соединении определяется, что IP-адрес узла получателя принадлежит удаленной сети. Узел-отправитель ищет в локальной таблице маршрутизации путь к узлу-получателю или его сети. Если путь не найден в таблице, узел-отправитель определяет IP-адрес шлюза по умолчанию. Затем он ищет в кэше протокола ARP соответствующий ему адрес сетевого адаптера.

Если этот адрес в кэше отсутствует, то широковещательный ARP-запрос используется для получения адреса шлюза, а не узла-получателя. Маршрутизатор (шлюз) в ответ на ARP-запрос узла-отправителя посылает адрес своего сетевого адаптера. Затем узел-отправитель адресует пакет на маршрутизатор для доставки его в сеть получателя и далее - узлу-получателю.

На маршрутизаторе выясняется, является ли IP-адрес получателя локальным или удаленным. Если он локальный, то маршрутизатор использует протокол ARP (кэш или широковещание) для получения его адреса сетевого адаптера. Если же - удаленный, маршрутизатор ищет в своей таблице маршрутизации необходимый шлюз, а затем использует протокол ARP (кэш или широковещание) для получения адреса его сетевого адаптера. Далее пакет отправляется непосредственно следующему получателю в этой цепочке.

Когда пакет достигнет получателя и будет обработан им, все исходящие пакеты таким же образом будут доставлены обратно. Например, при выполнении команды Ipng в ответ на эхо-запрос узел-получатель пакета формирует эхо-ответ протокола ICMP (ICMP echo-reply). Поскольку узел-отправитель находится в удаленной сети, в локальной таблице маршрутизации ищется адрес шлюза к сети узла-отправителя. Если поиск завершается успехом, адрес сетевого адаптера шлюза выясняется с помощью ARP.

Если адреса сетевого адаптера указанного шлюза нет в кэше протокола ARP, то для его определения используется широковещательный ARP-запрос. Как только адрес получен, эхо-ответ протокола ICMP посылается на маршрутизатор, который перенаправляет его на исходный узел-отправитель.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #35

Бинокль - ежедневное обозрение Internet, PC и новых информационных технологий.
"Бинокль" - это ежедневное сетевое обозрение, которое содержит новости из мира компьютерных и информационных технологий, анонсы разнообразных программ, а также обзоры нового аппаратного обеспечения и самых интересных веб-сайтов.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 35 от 27.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Разрешение локального IP-адреса

Перед соединением двух узлов IP-адрес каждого из них должен быть преобразован в адрес сетевого адаптера. Этот процесс состоит из выполнения ARP-запроса и получения ARP-ответа.

ARP-запрос формируется каждый раз при попытке одного узла связаться с другим. Если протокол IP определит, что IP-пдрес принадлежит локальной сети, узел-отправитель ищет адрес узла-получателя в своем собственном ARP-кэше.

Если он не найден, протокол ARP формирует запрос типа "Чей это IP-адрес и каков ваш адрес сетевого адаптера?", в который также включаются адреса IP и сетевого адаптера узла-отправителя. ARP-запрос посылается в широковещательном режиме, чтобы все узлы в локальной сети могли принять и обработать его.

Каждый узел в локальной сети получает этот широковещательный запрос и сравнивает указанный в нем IP-адрес со своим собственным. Если они не совпадают, запрос игнорируется.

Узел-получатель определяет, что IP-адрес в запросе совпадает с его собственным и посылает на узел-отправитель ARP-ответ, в котором указывает свой адрес сетевого адаптера. Затем он обновляет свой ARP-кэш, занося в него соответствие IP-адреса узла-отправителя адресу его сетевого адаптера. После того как узел-отправитель получает ARP-ответ, соединение может быть установлено.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #34

Энциклопедия оптимизации Windows
Выпуск # 34 от 25.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Протокол ARP

Для того чтобы установить соединение, узлам должны быть известны адреса сетевых адаптеров других узлов. Рпзрешение адреса (address resolution) - это процесс определения аппаратного адреса сетевого адаптера по его IP-адресу. Протокол ARP (Address Resolution Protocol) - часть уровня Интернета модели TCP/IP - позволяет определять адреса сетевых адаптеров узлов, расположенных в одной физической сети.

Протокол ARP нужен для получения вдресов сетевых адаптеров TCP/IP-узлов в сетях, поддерживающих широковещание. Он использует широковещательные запросы, содержащие IP-адрес получателя, чтобы выяснить адрес сетевого адаптера этого узла или адрес необходимого шлюза.

Получив адрес сетевого адаптера, ARP сохраняет его вместе с соответствующим IP-адресом в своем кэше. Протокол ARP всегда сначала ищет адреса IP и сетевого адаптера в своем кэше перед формированием широковещательного ARP-запроса.

Обратное разрешение адреса (reverse address resolution) - отображение адреса сетевого адаптера узла в его IP-адрес. Microsoft TCP/IP этот механизм не поддерживает.

Протокол ARP описан в RFC 826.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #33

Домашняя медицина..
Практические решения проблем со здоровьем, возникающие в каждой семье.
Подписаться. Рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 33 от 23.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Технологии сетевых интерфейсов

Протокол IP использует спецификацию интерфейса сетевого драйвера (Network Driver Interface Specification, NDIS) для передачи кадров модулям уровня сетевого интерфейса. IP поддерживает технологии сетевых интерфейсов как для локальных (LAN), так и для глобальных (WAN) сетей.

Поддерживаемые протоколом TCP/IP технологии LAN включают Ethernet (Ethernet II и 802.3), Token Ring, ArcNet и технологии MAN (Metropolitan Area Network).

Для использования TCP/IP в глобальных сетях требуется служба удаленного доступа Windows NT RAS (Remote Access Service) или дополнительное аппаратное обеспечение. Существуют две основные категории оборудования WAN, поддерживаемого протоколом TCP/IP: последовательные линии связи (serial lines) и сети с коммутацией пакетов (packet-switched networks). Последние включают технологи. X.25, сети с ретрансляцией кадров (frame relay) и сети асинхронной передачи.

По телефонным линиям данные TCP/IP обычно передаются при помощи протоколов SLIP (Serial Line Internet Protocol) или PPP (Point-to-Point Protocol).

Протокол SLIP - промышленный стандарт, разработанный в начале 80-х годов для поддержки TCP/IP при соединении через низкоскоростные последовательные интерфейсы. Применяя службу Windows NT RAS, компьютеры под управлением Windows NT могут использовать протоколы TCP/IP и SLIP для связи с удаленными узлами. Windwows NT поддерживает только клиентскую часть протокола SLIP, но не SLIP-сервер. Серверы Windows NT RAS не могут устанавливать соединения со SLIP-клиентами.

Протокол PPP, разработанный как расширение SLIP, является протоколом канального уровня (data-link protocol) и обеспечивает стандартный метод передачи сетевых пакетов через соединение типа точка-точка (point-to-point link). Поскольку протокол PPP обеспечивает лучшую защиту, управление конфигурацией и обнаружение ошибок, чем протокол SLIP, на последовательных линияхрекомендуется использовать именно его.

Передача данных протокола IP по телефонным линиям описана в RFC 1055. Протокол PPP описан в RFC 1547 и RFC 1661.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #32

Новости Кондитерского Рынка.
Новости кондитерского рынка: производство, преспективы, прогнозы и оценки. Аналитические материалы по сегментам рынка. Обзоры экономической ситуации в отрасли. Освещаются все значительные события на кондитерских предприятиях России.
Подписаться. Золотые рассылки Subscribe.Ru
Энциклопедия оптимизации Windows
Выпуск # 32 от 20.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Четырехуровневая модель TCP/IP

Протоколы семейства TCP/IP можно представить в виде модели, которая состоит из четырех уровней: приложения (Application layer), транспортного (Transport layer), межсетевого, или уровня Интернета (Internet layer) и сетевого интерфейса (Network Interface layer). Основные протоколы TCP/IP - это набор стандартов для соединения компьютеров и межсетевого взаимодействия.

Приложения Windows Sockets | Приложения NetBIOS | Уровень приложения
TCP | UDP | Транспортный уровень
IP |  | Межсетевой уровень
Технологии LAN | Технологии WAN | Сеть

В основании этой модели лежит уровень сетевого интерфейса. Соответствующие компоненты отвечают за отправку в сеть и прием из сети кадров, содержащих пакеты информации. Кадры передаются по сети как единое целое.

Протоколы Интернета инкапсулируют пакеты данных в датаграммы Интернета и проводят необходимую маршрутизацию. Четыре основных протокола Интернета предназначены:

  • IP (Internet Protocol) - в основном для отправки и маршрутизации пакетов между сетями и узлами.
  • ARP (Address Resolution Protocol) - для получения адресов сетевых адаптеров узлов в рамках одной физической сети.
  • ICMP (Internet Control Message Protocol) - для отправки извещений и сообщений об ошибках, связанных с доставкой пакетов.
  • IGMP (Internet Group Management Protocol) - используется IP-узлами для сообщения поддерживающим групповую передачу маршрутизаторам о своем участии в группах.

Транспортный уровень обеспечивает сеансы связи между компьютерами. Существует два транспортных протокола: TCP (Transmission Control Protocol) и UDP (User Datagram Protocol). Использование одного из них зависит от выбранного метода доставки данных.

TCP ориентирован на соединение и используется приложениями, обычно передающими большие объемы данных за одну операцию, так как обеспечивает надежное соединение, а также приложениями, которым необходимо подтверждение приема данных.

Протокол UDP обеспечивает не ориентированную на соединение передачу данных и не гарантирует доставку пакетов. Приложения, использующие протокол UDP, обычно передают небольшие объемы данных за одну операцию. Ответственность за надежную доставку данных несет само приложение.

Венчает модель TCP/IP уровень, на котором приложения получают доступ к сетевым компонентам. Здесь работает множество стандартных утилит и сервисов протокола TCP/IP, например FTP, Telnet, SNMP и DNS.

Протокол Microsoft TCP/IP предоставляет сетевым приложениям два различных интерфейса к сервисам TCP/IP. Первый из них - Сокеты Windows (Windows Sockets) - обеспечивает стандартный интерфейс прикладного программирования под Windows для работы с такими транспортными протоколами, как TCP/IP и IPX. Второй - NetBIOS - стандартный интерфейс к протоколам, поддерживающим имена и сообщения NetBIOS, например TCP/IP и NetBEUI.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #31

Энциклопедия оптимизации Windows
Выпуск # 31 от 18.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Тестирование TCP/IP

После установки протокола TCP/IP полезно проверить и протестировать конфигурацию и все соединения с другими узлами TCP/IP и сетями.

Вы можете использовать утилиту Ipconfig (Winipcfg в Windows 95) для проверки параметров конфигурации узла, включая IP-адрес, маску подсети и шлюз по умолчанию. Это полезно при выяснении, успешно ли прошла инициализация TCP/IP и не дублируется ли IP-адрес, указанный в конфигурации. Синтаксис команды:

ipconfig

Если протокол инициализировался успешно с заданной конфигурацией, то на экране отобразятся IP-адрес, маска подсети и шлюз по умолчанию. Если адрес, заданный в конфигурации, уже используется другим узлом в сети на том же сегменте, то отобразится заданный IP-адрес, но маска подсети будет равна 0.0.0.0.

После проверки конфигурации утилитой Ipconfig вы можете запустить утилиту Ping (Packet Internet Grouper) для тестирования соединений. Это диагностическое средство тестирует конфигурации TCP/IP и позволяет определить неисправности соединения. Утилита Ping использует пакеты эхо-запроса (echo request) и эхо-ответа (echo reply) протокола ICMP (Internet Control Message Protocol) для проверки доступности и работоспособности определенного узла TCP/IP. Синтаксис команды:

ping IP-адрес

Если проверка прошла успешно, то отобразится сообщение типа:

Pinging IP-адрес with 32 bytes of data:
Reply from IP-адрес: bytes= x time<10ms TTL = x
Reply from IP-адрес: bytes= x time<10ms TTL = x
Reply from IP-адрес: bytes= x time<10ms TTL = x
Reply from IP-адрес: bytes= x time<10ms TTL = x


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #30

Энциклопедия оптимизации Windows
Выпуск # 30 от 16.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Установка и настройка TCP/IP

При установке TCP/IP создается несколько системных файлов и файлов разрешения имен. TCP/IP использует следующие файлы разрешения имени:

Файл конфигурации | Описание
HOSTS | Обеспечивает разрешение имен узлов в IP-адреса.
LMHOSTS | Обеспечивает разрешение имен NetBIOS в IP-адреса.
NETWORKS | Обеспечивает резрешение имен сетей в идентификаторы сетей.
PROTOCOL | Преобразует имя протокола в идентификатор протокола, заданный в RFC. Номер протокола - это поле в заголовке IP-пакета, идентифицирующее, какому протоколу верхнего уровня (например, TCP или UDP) будут переданы данные протокола IP.
SERVICES | Обеспечивает преобразование имени сервиса в номер порта и имя протокола. Номер порта - это поле в заголовке TCP или UDP-пакета, идентифицирующее процесс, использующий TCP или UDP.

Протокол TCP/IP использует IP-адрес, маску подсети и шлюз по умолчанию для соединения с узлами. Узлы TCP/IP, работающие в глобальной сети, требуют задания всех трех параметров в конфигурации. Каждая плата сетевого адаптера в компьютере, использующем TCP/IP, нуждается в этих параметрах.

IP-адрес - это логический 32-разрядный адрес, однозначно определяющий узел TCP/IP. Каждый IP-адрес состоит из двух частей: идентификатора сети и идентификатора узла. Первый служит для обозначения всех узлов в одной физической сети. Второй обозначает конкретный узел в сети. Каждому компьютеру, использующему TCP/IP, требуется уникальный IP-адрес, например, 131.107.2.200.

Маска подсети выделяет часть IP-адреса и позволяет TCP/IP отличить идентификатор сети от идентификатора узла. Пытаясь связаться, узлы TCP/IP используют маску подсети (например, 255.255.255.0), чтобы определить, находится узел-получатель в локальной или удаленной сети.

Для того чтобы установить соединение с узлом из другой сети, вы должны сконфигурировать IP-адрес шлюза по умолчанию. TCP/IP посылает пакеты, предназначенные для удаленных сетей, на шлюз по умолчанию, но только в том случае, если на локальном узле не сконфигурирован другой маршрут к сети получателя. Если вы не сконфигурируете шлюз по умолчанию, то связь может быть ограничена локальной сетью.

Зайдите на Панель управления, а затем в раздел "Сеть". Если TCP/IP не числится в списке установленных сетевых протоколов, необходимо его установить. Затем выделите TCP/IP и нажмите на кнопку "Свойства". Если ваш компьютер включен в большую сеть, необходимо убедиться, что имя компьютера, домена и информация об IP-адресе не конфликтуют с сетью. В отличие от IP-адреса и маски подсети шлюз по умолчанию является необязательным параметром. Если вы его опустите, то область работы вашего компьютера ограничится локальной сетью.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #29

Это полезно!
Все новинки компьютерной литературы
в рассылках Co@Libri на Subscribe.ru.
Подпишись и совершенствуйся. Выходит дважды в неделю.
Реклама
Энциклопедия оптимизации Windows
Выпуск # 29 от 13.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Утилиты TCP/IP

Windows поддерживает ряд утилит, облегчающих использование протоколов нижних уровней. Утилиты Microsoft TCP/IP работают с протоколами TCP/IP, обеспечивая доступ к другим узлам и Интернету. В Windows все утилиты реализованы только как клиентское программное обеспечение, за исключением протокола FTP, реализованного в качестве программного обеспечения и клиента и сервера. Протокол FTP обеспечивает двухстороннюю передачу файлов между узлами TCP/IP, на одном из которых исполняется программное обеспечение FTP-сервера.

Остальные утилиты, используемые для передачи данных, реализуют протоколы Trivial File Transfer Protocol (TFTP) и Remote Copy Protocol (RCP). Первый, подобно FTP, обеспечивает двухстороннюю передачу файлов между узлами протокола TCP/IP, один из которых работает под управлением программного обеспечения сервера TFTP. Второй копирует файлы между компьютером, работающим под управлением Windows и хостом UNIX.

Windows также имеет утилиты для соединения и удаленной работы с другими узлами TCP/IP. Наиболее часто используемая утилита удаленного выполнения - Telnet. Она обеспечивает эмуляцию терминала узла TCP/IP, на котором выполняется программное обеспечение сервера Telnet. Кроме того, применяется утилита RSH (Remote Shell), выполняющая команды на хосте UNIX, и REXEC (Remote Execution), запускающая процесс на удаленном компьютере.

Две утилиты TCP/IP отвечают за печать и получение данных о состоянии принтера, поддерживающего TCP/IP. Утилита LPR (Line Printer Remote) печатает файл, передавая его на узел, где работает сервис LPD (Line Printing Daemon). Утилита LPQ (Line Printer Queue) предоставляет сведения об очереди печати на узле, где работает сервис LPD.

Эти утилиты требуют наличия специального рпограммного обеспечения на компьютерах клиента и сервера. Microsoft предоставляет программное обеспечение серверов FTP и LPD.

Windows предоставляет несколько утилит для диагностики неисправностей, характерных для протокола TCP/IP.

Утилита | Описание
Ping (Packet Internet Grouper) | Проверяет корректность конфигурации протокола TCP/IP и доступность другого узла.
Ipconfig (в поставке Windows 95 Winipcfg) | Проверяет конфигурацию протокола TCP/IP, включая адреса серверов DHCP, DNS и WINS.
Finger | Получает системную информацию с удаленного компьютера, поддерживающего сервис Finger.
Nslookup | Позволяет просматривать записи в базе данных сервера DNS, относящиеся к тому или иному узлу или домену.
Hostname | Возвращает имя локального компьютера для аутентификации.
Netstat | Отображает статистику протокола и текущее состояние соединений TCP/IP.
Route | Просматривает или изменяет локальную таблицу маршрутизации.
Tracert | Прослеживает маршрут от локального до удаленного узла.
Arp (Address Resolution Protocol) | Отображает локальный кэш соответствий IP-адресов адресам сетевых адаптеров.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #28

холодная распродажа
Для комфорта в жару и холод!
Лучшие отечественные и импортные
кондиционеры от производителя.
Подробнее - www.condi.ru
Связь: (095)702-94-12 E-mail 		Реклама
Энциклопедия оптимизации Windows
Выпуск # 28 от 11.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Документы RFC

Международная общественная организация, именуемая Сообществом Интернета (Internet Society, ISOC), управляет развитием семейства протоколов TCP/IP. Стандарты для TCP/IP публикуются в сериях документов, называемых RFC (Request for Comments). Хотя Интернет не является собственностью ни одной организации, некоторые из них отвечают за управление им.

Сообщество Интернета образовано в 1992 году и отвечает за технологии межсетевого взаимодействия и использование сети. Поскольку основная цель сообщества - развитие и доступность Интернета, оно регулирует выработку стандартов и протоколов, позволяющих ему функционировать.

Архитектурная Группа Интернета (Internet Architecture Board, IAB) входит в состав ISOC. Эта консалтинговая техническая группа отвечает за установку стандартов Интернета, публикацию RFC и наблюдение за процессом стандартизации сети.

Группа IAB руководит группами IETF (Internet Engineering Task Force), IANA (Internet Essigned Numbers Authority) и IRTF (Internet Research Task Force). Группа технической поддержки Интернета (IETF) разрабатывает стандарты и протоколы Интернета и решает технические проблемы по мере их возникновения в сети. IANA наблюдает и координирует назначение каждого уникального идентификатора протокола, применяемого в Интернете. Группа IRTF координирует все исследовательские проекты в области TCP/IP.

Стандарты для протокола TCP/IP публикуются в виде серии документов "Запрос комментариев" (Request for Comments, RFC). Они описывают устройство Интернета. Стандарты TCP/IP всегда публикуются в RFC, но не все RFC описывают стандарты.

Стандарты протоколов TCP/IP разрабатываются не специальной группой, а, скорее, всем сообществом. Любой член ISOC может представить на рассмотрение документ для его публикации в серии RFC. После этого документы просматриваются техническим экспертом, группой разработчиков или редактором RFC, а затем классифицируются. В классификации указывают, обсуждается ли документ в настоящее время, или он уже принят в качестве стандарта. Существует пять типов RFC.

Классификация | Описание
Required (Требуется) | Стандарт должен быть реализован на всех основанных на TCP/IP узлах и шлюзах.
Recommended (Рекомендуется) | Предлагается реализовать спецификации RFC на всех основанных на TCP/IP узлах и шлюзах. Рекомендуемые RFC обычно реализуются.
Elective (Избирательно) | Реализация не обязательна. Применение согласовано, но используется нешироко.
Limited use (Ограниченное использование) | Не рекомендуется для всеобщего применения
Not recommended (Не рекомендуется) | Реализация не рекомендуется.

Если документ рассматривается в качестве потенциального стандарта, то он проходит все стадии разработки, тестирования и утверждения. В процессе стандартизации Интернета эти стадии формально именуются уровнями готовности (maturity levels). Существует три вида готовности стандартов Интернета.

Уровень готовности | Описание
Proposed Standart (Предлагаемый стандарт) | Устоявшаяся спецификация, в которой разрешены спорные моменты. Она уже оценена сообществом и считается достаточно перспективной.
Draft Standart (Черновой стандарт) | Должен быть хорошо понятен и устойчив в качестве основы для последующей реализации.
Internet Standart (Стандарт Интернета, или просто стандарт) | Характеризуется высокой степенью технической завершенности. Предполагается, что описанный протокол или сервис предоставляет существенные преимущества всем в Интернете.

При публикации документ получает номер RFC. Первоначальный вариант RFC никогда не обновляется. Если RFC нуждается в изменениях, то обновленная версияпубликуется под текущим номером. Поэтому важно убедиться в том, что у вас находится самый "свежий" RFC на интересующую вас тему. Группа IAB публикует официальный стандарт протоколов IAB (IAB Protocol Standart) - ежеквартальную заметку с перечнем самых последних RFC для каждого протокола на текущий момент.


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #27

Энциклопедия оптимизации Windows
Выпуск # 27 от 09.07.01
http://www.windows.sl.ru
Доброе время суток, уважаемые подписчики!

Всего в голосовании по поводу публикации статей о TCP/IP приняло участие 450 человек. Из них:

  • За - 433 (96%)
  • Против - 17 (4%)

Результат говорит сам за себя. Итак, начиная с этого выпуска в рассылке будут публиковаться статьи о TCP/IP. Напомню, что авторские права на оригинальные статьи и их перевод принадлежат корпорации Microsoft.

Кроме того, есть и технические изменения. В связи с моим отпуском до конца августа рассылка будет выходить в автоматическом режиме. Дни выхода - понедельник, среда, пятница, время выхода - 15-00 (MSK).

Что такое TCP/IP, какими преимуществами он обладает

Семейство протоколов TCP/IP (Transmission Control Protocol/Internet Protocol) - это стандартный промышленный набор протоколов, разработанный для глобальных вычислительных сетей (Wide Area Networks, WAN).

Протокол TCP/IP был создан в результате исследований сетей с коммутацией пакетов (packet-switching networks), проводимых агентством DARPA (U.S. Department of Defence Advanced Research Projects Agency) в конце 60-х - начале 70-х годов. В эволюции TCP/IP можно отметить несколько важных этапов.

Год | Событие
1970 г. | Узлы сети ARPANET начали использовать протокол NCP (Network Control Protocol).
1972 | Первая спецификация Telnet оформлена как RFC 318.
1973 | Введен протокол File Transfet Protocol, RFC 454.
1974 | Представлена программа Transmission Control Program (TCP).
1981 | В RFC 791 опубликован стандарт IP.
1982 | Агентство DCA (Defence Communications Agency) и агентство ARPA объединили протокол TCP (Transmission Control Protocol) и IP (Internet Protocol) в набор TCP/IP.
1983 | Сеть ARPANET переключилась с протокола NCP на протокол TCP/IP.
1984 | Введена доменная система имен (Domain Name System, DNS).

Протокол TCP/IP в Windows NT и 2000 обеспечивает сетевое взаимодействие компьютеров предприятия, работающих под управлением Windows NT и 2000, и возможность подключения к ним сетевых устройств и компьютеров под управлением других операционных систем. Добавление протокола TCP/IP в конфигурацию Windows обеспечивает ряд преимуществ. Основной плюс - TCP/IP оправданно считается наиболее совершенным и распространенным протоколом из всех доступных на сегодняшний день. Все современные операционные системы поддерживают протокол TCP/IP, и почти все крупные сети используют его для обеспечения большей части своего трафика. Кроме того протокол TCP/IP является стандартным для Интернета.

Другое преимущество технологии TCP/IP - возможность объединения неоднородных систем. Сегодня существует множество утилит доступа и передачи данных, позволяющих взаимодействовать самым различным системам. Некоторые из них, например FTP (File Transfer Protocol) и Telnet, поставляются с Windows NT Server.

Протокол TCP/IP, кроме того, - масштабируемый каркас для разработки приложений, использующих архитектуру клиент/сервер. Применяя протокол TCP/IP, компания Microsoft обеспечивает интерфейс Сокетов Windows (Windows Sockets) - стандартный сетевой интерфейс прикладного программирования для приложений Windows. Приложения Windows Sockets пользуются всеми преимуществами других сетевых протоколов, например Microsoft NWLinks, используемого в сетях Nowell NetWare.


Created using
htm2chm 3.0

Download it NOW!


Subscribe.Ru : Энциклопедия оптимизации Windows Выпуск #48

-= Содержание =-

Что такое TCP/IP и какими преимуществами он обладает

Четырёхуровневая модель TCP/IP

Протокол UDP

Протокол TCP

Протокол IP

Протокол ARP

Структура ARP-пакета

Кеш протокола ARP

Протокол IGMP

Протокол ICMP

Порты и Сокеты

Структура TCP-пакета

Структура IP-пакета

Разрешение удалённого IP-адреса

Разрешение локалного IP-адреса

Реализация IP на маршрутизаторе

Установка связи по протоколу TCP

Установка и настройка TCP/IP

Тестирование TCP/IP

Утилиты TCP/IP

Технологии сетевых интерфейсов

Документы RFC